Metamorphose Fórum

Assuntos relacionados ao sistema operacional Metamorphose Linux, aqui você poderar tirar suas duvidas e dar opiniões.

Buscar
 
 

Resultados por:
 


Rechercher Busca avançada

Tópicos similares
    Últimos assuntos
    » Nova Versão 2018
    Permissões em arquivos, diretórios e partições no metamorphose EmptyDom Abr 08, 2018 12:30 am por Maxmiliano

    » Firewall Metamorphose
    Permissões em arquivos, diretórios e partições no metamorphose EmptyDom Fev 04, 2018 7:33 am por Fabio da Silva Crochik

    » Firefox no Linux Metamorphose
    Permissões em arquivos, diretórios e partições no metamorphose EmptyQui Ago 31, 2017 9:58 am por LINUXMACEIO

    » GOSTEI E JÁ COMECEI A DIVULGAR
    Permissões em arquivos, diretórios e partições no metamorphose EmptyQua Ago 02, 2017 12:25 pm por agnaldo

    » Criticas e sugestões
    Permissões em arquivos, diretórios e partições no metamorphose EmptyQua Maio 24, 2017 7:47 pm por R0CK-BR

    » Baixar via torrent
    Permissões em arquivos, diretórios e partições no metamorphose EmptySeg Maio 22, 2017 5:04 am por dantonrenato

    » Sistema em .vmx?
    Permissões em arquivos, diretórios e partições no metamorphose EmptyQui Maio 18, 2017 5:49 pm por thilokoo

    » problemas com driver de video
    Permissões em arquivos, diretórios e partições no metamorphose EmptyTer Abr 25, 2017 1:36 pm por marinaldo

    » Portugês PT
    Permissões em arquivos, diretórios e partições no metamorphose EmptySex Abr 21, 2017 9:37 am por luizbranco

    Navegação
     Portal
     Índice
     Membros
     Perfil
     FAQ
     Buscar

    Você não está conectado. Conecte-se ou registre-se

    Permissões em arquivos, diretórios e partições no metamorphose

    Ir em baixo  Mensagem [Página 1 de 1]

    Natan


    Tenho encontrado, vez por outra, um probleminha de permissões no ambiente do meta. As vezes trabalhando com arquivos no BrO não tenho permissões de gravar em uma partição fat32. Outro momento, por meio do ícone Home, abro o gerenciador de arquivos e aí vou montar uma partição e o sistema diz que não tenho o Hal. Pelo synaptic o Hal está instalado. Então eu abro o gerenciador de arquivos por meio do ícone Meu Computador e aí partição pode ser montada e acessada normalmente como usuário meta, com acesso para leitura e escrita. Aí copio algum arquivo salvo no /home/meta para a partição desejada. Alguém sabe como resolver isso? Inserindo opções no etc/fstab no metamorphose acho que não é possível, já que a cada boot o fstab volta a versão anterior. Obrigado pela atenção.

    richex

    richex
    Este tipo de problema com permissão pode ser resolvido apenas alterando o arquivo /etc/fstab. Poste o seu fstab e vejamos o que pode ser feito. Abra um terminal como root e faça o comando:

    Código:

    # kwrite /etc/fstab

    Copie e cole o conteúdo aqui. Sobre ele voltar ao formato anterior, isso nao acontece sozinho.; voce deve ter feito algum comando para restaurar o backup.

    http://www.comunidadeabiblia.net

    Natan


    Meu fstab é este:
    # /etc/fstab: static file system information
    #
    # <file system> <mount point> <type> <options> <dump> <pass>

    # adicionado por metamorphose /dev/sda6
    /dev/sda6 / reiserfs defaults 0 1

    # adicionado por metamorphose /dev/sda1
    /dev/sda1 /mnt/sda1 auto noauto,users,exec 0 0

    # adicionado por metamorphose /dev/sda2
    /dev/sda2 /mnt/sda2 auto noauto,users,exec 0 0

    # adicionado por metamorphose /dev/sda3
    /dev/sda3 /mnt/sda3 auto noauto,users,exec 0 0

    # adicionado por metamorphose /dev/sda5
    /dev/sda5 /mnt/sda5 ext3 noauto,users,exec 0 0

    # adicionado por metamorphose /dev/sda7
    /dev/sda7 none swap sw 0 1

    # adicionado por metamorphose
    /dev/cdrom /media/cdrom udf,iso9660 user,noauto 0 0

    sys /sys sysfs noauto 0 0
    /dev/pts /dev/pts devpts mode=0622 0 0
    usbfs /proc/bus/usb usbfs defaults 0 0

    Obrigado pela atenção.

    richex

    richex
    Voce deve acrescentar a opção umask=000 na linha referente à partição fat. Por exemplo ser for a sda2

    Agora está assim:


    # adicionado por metamorphose /dev/sda2
    /dev/sda2 /mnt/sda2 auto noauto,users,exec 0 0

    Então voce deve deixar assim:


    # adicionado por metamorphose /dev/sda2
    /dev/sda2 /mnt/sda2 vfat noauto,users,exec,umask=000 0 0

    Se quiser tambem que a partição seja montada automaticamente no boot é so mudar outra opção de noauto para apenas auto. Ficando assim:


    # adicionado por metamorphose /dev/sda2
    /dev/sda2 /mnt/sda2 vfat auto,users,exec,umask=000 0 0


    Nota:

    Se for partição fat: umask=000
    Se for partição nftg: umask=0

    http://www.comunidadeabiblia.net

    Natan


    Fiz como richex indicou, pelo terminal, como root, salvei o arquivo e reiniciei o pc, mas quando abri o fstab ele estava sem as opções como foram colocadas por mim. O fstab que salvei agora está no fstab.old.
    Obrigado pela força, valeu richex.

    Natan


    Já fiz várias tentatiras de mudar as permissões de alguns arquivos e diretórios em uma partição fat32, mas não tive sucesso.
    Usei chmod e chown mas nenhum comando foi capaz de alterar as permissões para o usuário, mesmo como root. Veja um resumo abaixo:

    meta@NATAN:/mnt$ su
    Senha:
    root@NATAN:/mnt# chown meta:meta /mnt/sda3
    chown: mudando permissões de `/mnt/sda3': Operação não permitida
    root@NATAN:/mnt# cd sda3

    root@NATAN:/mnt/sda3/meusdoc# ls
    teste.doc
    Teste do Office.doc
    teste.odp

    root@NATAN:/mnt/sda3/meusdoc# chown meta:meta teste.doc
    chown: mudando permissões de `teste.doc': Operação não permitida
    root@NATAN:/mnt/sda3/meusdoc# chown 1000:1000 teste.doc
    chown: mudando permissões de `teste.doc': Operação não permitida

    root@NATAN:/mnt/sda3/meusdoc# chmod 777 teste.doc
    root@NATAN:/mnt/sda3/meusdoc# chmod 666 teste.doc

    Esse arquivo teste.doc após esses comandos continuam só abrindo no BrO só para leitura.

    Obrigado pela atenção.

    richex

    richex
    Tenta então:


    # chmod +x nomedoarquivo.doc

    http://www.comunidadeabiblia.net

    Natan


    O comando chmod +x também não mudou as permissões nem de um arquivo nem de uma pasta.
    Tá difícil trabalhar com o meta desse jeito as partições ficam bloqueadas para gravação. Se não mudar na nova versão do meta vou usar só o Big Linux que está mais amigável nesse aspecto.

    Conteúdo patrocinado


    Voltar ao Topo  Mensagem [Página 1 de 1]

    Permissão deste fórum:
    Você não pode responder aos tópicos neste fórum